Computer Art and Animation: A Brief Beginner’s Guide

An Honors Thesis (ART 490)

by

Shelby Smith

Thesis Advisor
Andy Beane

Ball State University
Muncie, Indiana

May 2014

Expected Date of Graduation

May 2014
Abstract

Creating computer animation and art can be a very challenging process. Software programs used for these processes can be very large, complicated, and can have a steep learning curve. Not only that, but working with computers comes with a fair share of bugs and glitches. Both of these factors mean that creating art on computers requires research, practice, and a large amount of determination. This guide will hopefully alleviate some of that frustration for anyone reading it. My final year in the animation program at Ball State University consisted of building a portfolio of work for employers, all pieces of which came with their fair share of frustrations. This is a brief guide explaining how all of these projects were made. It will give a summary of all of the steps involved in the year’s projects. I will share my experience working with these programs so that anyone reading this thesis can have the knowledge to get started in this field.

Acknowledgements

I would like to thank Mr. Andy Beane for helping me in both learning this material and assisting me with writing the thesis. I would also like to thank Brian Ludwick, who also passed on his knowledge to me during my four-year career here at Ball State University.

I would also like to thank my very supportive and understanding family, as well as my fellow animation students who encouraged me along the way.
# Table of Contents

**Introduction**
- 1

**General Tips**
- 2

**Designing Characters**
- 3
  - 3
  - 4
  - 6
  - 7
  - 9
  - 11
  - 13
  - 14
  - 15
  - 16
  - 19
  - 20

**Layers**
- 5

**Drawing Line Work**
- 6

**Coloring the Piece**
- 7

**Adobe Kuler**
- 8

**Background**
- 9

**Completion**
- 10

**3D Character Rig**
- 11
  - 14
  - 15
  - 16
  - 19

**Set Up**
- 12

**Moving Inside Maya**
- 13

**Placing the Character**
- 14

**Modeling**
- 15

**Manipulating Geometry**
- 16

**Extrude**
- 17

**Insert Edge Loops**
- 18

**Slide Edge Tool**
- 19

**Modeling the Parts**
- 20

**Edge Flow**
- 21

**Modeling joints**
- 22

**Symmetry**
- 23

**Textures**
- 24

**In-Maya Textures**
- 25

**Out-of-Maya Textures**
- 26

**Rigging**
- 27

**Skeleton**
- 28

**IK/FK Arms**
- 29

**Skinning**
- 30

**Controllers 31**
- 31

**IK/FK Switch and Set Driven Key**
- 32

**Animating the Rig**
- 33

**2D Character Rigs**
- 34

**Importing the File**
- 35

**Setting Up the Rigs**
- 36

**Controlling the Rig**
- 37

**Slider Controls**
- 38

**Parenting Controls in Separate Compositions**
- 39

**Animating the Rig**
- 40

**Pen Render Test**
- 41

**Textures**
- 42
Lighting

Rendering 58

Ambient Occlusion

Render Settings 60

Batch Render 61

Importing Image Sequences

Compositing Sequences 62

Rendering 63

Conclusion 64
Introduction

Art has been a very prominent part of human society ever since prehistoric times. As technology has advanced, so has the art world. New technologies bring about new methods and features for the art world to learn and use. Sometimes, technology will even bring new genres of art entirely, such as animation. Animation has taken as the little time that it has had and very strongly secured its presence much of all of the world’s society.

Just like the rest of the art world, animation has advanced with technology as well. More technology means that there are plenty of ways to create animation, especially with the flexibility modern computers offer today. Despite the advanced state of modern technology, however, creating art and animation digitally is still rather complicated.

Working in any of the following programs can be daunting at first glance. This guide’s purpose is to present some basic tools that beginners can use to take their first step in creating digital artwork. These projects were created for a senior-year demo reel in Ball State’s animation program. Each one has its own process and uses a variety of tools and programs. This guide is a brief look into animation software, and is intended to display some basic abilities inside of the programs. Included with this guide is a CD-ROM, which has all of the files below collected into one resource. Hopefully, explaining some of the basics can make the transition into this world a little smoother.

General Tips

Creating digital artwork involves many different programs, each with their own concepts and learning curves. Some aspects of these programs may cross over some, but they are generally very separated from each other. There are some rules, however, that apply to everything an artist does. These are some rules that apply to all aspects of digital art:

1. Stay Organized
   Just like any other facet of art (or life in general), it pays to stay organized. Many of these projects required a fairly large number of assets that all need to be saved together in a format that makes sense. It is also fairly helpful to have the ability to find files when working on a project. Personal artists can organize themselves however they please. Some artists, however, find themselves working in a group project with multiple people. Agreeing on a type of organization in that situation is an absolute must. Without organization, especially in a group project, the final product will quickly fall apart.

2. Save Sequentially
   Sometimes, when working with computers, a program can crash un-expectantly. This will actually happen more often with programs designed for art and animation. As more work is saved in these files, they become bigger and have more information going in and
out of them. This can be a burden to the computer and maybe even more than it can handle.

These files can be very numerous, which is not bad at all. The character designs in this portfolio created 24 separate files. The 2d rigs created 22 files, and the 3d rig was a whopping 76 files (3d programs are especially notorious for crashes). Crashes are inevitable, and saving a new file on a regular basis can help avoid a worst-case-scenario. This way, if a program crashes, a previous version of the file can be opened and the artist will lose as little work as possible.

3. Get Critiques

Any artist should be open to gaining another perspective on the work they are making. Artists can very easily become caught up in their work, and either miss some detail or become overly attached to something. Another person will look at a piece from their unique perspective, and can give some significant insight. Also, do not get critiques from parents. They may be nice people, but typically they either A) don’t know about the field at all, or B) are too concerned about hurting feelings in order to offer criticism.

4. Practice

Just like everything else in life, this sort of work requires practice. No one will be perfect at creating anything right away. Even if something ends up being bad, keep on making work. If there is actual effort put in place, an artist’s work will only get better and better as more is made.

5. Everything is Subjective

There is something incredibly important about making digital work: there are never any right answers. These computer programs all have a large range of tools for a large range of possibilities. The following projects could all have been done in multiple ways; these examples are just one person’s methods. Any method of performing any task in any program is up to the individual.

Designing Characters

Photoshop is generally known as a photo editing program for most people, but has become an incredibly useful tool in the realm of digital art. Its wide array of tools and features make it an industry standard for digital drawing and painting.

Within the animation industry, it is essential to design all of the assets of a project before beginning, especially the characters. These projects of the reel were meant to demonstrate the skill of being able to present characters effectively.
Photoshop
The demo reel accompanying this manual shows a handful of character designs that used a similar process. This process takes a general idea of a character and displays it so that any artist can follow the (similar to a blueprint). As an example, this section will show the development of a cute bug character.

Creating a Document
Once Photoshop is opened, it will show as a completely blank slate with no canvas. Naturally, the first thing to do is create a new file, which we by going to File \(\rightarrow\) New in the upper-left-hand corner. This will bring up a new box with several different settings.
These settings dictate the size and resolution of your file. Some of these settings, such as color mode and color profile, are not touched all that often (and we will not adjust them here).

Note that when changing size, there is an option to change it according to inches. The drag-down menu in these boxes can change the document’s units to pixels, centimeters, millimeters, and more. What size should be used is purely dictated by what the user’s own judgment at that given time.

Setting the document’s resolution is a similar process. The set resolution will dictate how detailed an image can get and how much information can be shown in a given section of the document. It is typically good to have it set to at least 300 pixels per inch. If working on a large-scale painting or something similar, it may be a good idea to set it higher. This character’s design will set it at 4500 by 2357 pixels at 300 resolution.

**Changing Settings**

While working in a document, it may be clear that certain sizes would be better than others for the work. This project had that problem, and ultimately had its size tweaked to a more suitable size. The preset sizes of any document can be changed at any point. There are two ways to do this, and they are both found in the “Image” dropdown menu. The first is “Image Size”.
This option will resize the image equally on either side of the entire image. For example, if the width were changed to add 500 pixels, the change would add 250 pixels on each side. This option will also resize any layers and drawings in the document.

Notice that there is also a “Constrain Proportions” option. Once that option is checked, both width and height will change together to keep the image’s proportions. This is ideal to prevent any bizarre stretching and squashing of the image.

The second option is called “Canvas Size”. Unlike the Image Size option, Canvas Size will only change the size of the actual drawing area; any images created in the document will remain unchanged.
The canvas' size can change either by entering a new value for the size or by choosing how many pixels/inches/etc. to add. Changing between these options is done by checking or unchecking the "Relative" box.

Near the bottom of this option box is the Anchor. This option dictates which direction the canvas will spread its new size. Its default setting is to spread the size all around evenly, just as the Image Size option would do. Clicking anywhere in the anchor's grid will determine whether the canvas will spread up, down, left, right, or from a corner.

Roughing

When drawing any image, be it in Photoshop or on paper, it is best to work from a rough image to a detailed one. Artists very rarely draw an image in detail straight away. They begin with the basic shape and shading of their subject and gradually work in more and more detail (or as much detail as they are striving for).

This first example is the design process for a bug-like creature. It will consist of a "turnaround". A turnaround is an image that shows a character from every angle. This will give designers and other artists all the information they need to turn the character into an animation, illustration, or any other art asset.

With that, the design begins rough, building up the basic shapes of the character.

The bottom of this illustration has some loose lines to gain a sense of what the creature will look like. From there, some brief sketches of the creature from each notable angle are drawn roughly using the Paintbrush tool (the Paintbrush tool will be covered in the Final Line work section). It should be noted that these are not the first or only roughs made, but are the final roughs after drawing and testing different angles and features. It is incredibly wise to draw
a character multiple times and experiment with its features before committing to a final draft. That way, an artist can critically look at that character and decide what is working and what is not.

**Final Line Work**

Once the roughs are finished, the next step is to add final line work. The final line work will be separated from the roughs, but be stacked on top of them in its own section. This can be done in Photoshop with layers.

**Layers**

Layers allow for multiple images or colors to stack on top of each other without merging them together. This way, the artist can adjust each section of the document without altering another section. This character designs will have the roughs, lines, and colors on separate layers so that each of those components can be altered by itself.

A layer can be added by going to **Layer→New→Layer** in the top menu or with the shortcut **CTRL+Shift+N**. By default, these layers will simply stack on top of one another. After adding them, however, a variety of effects can be applied to each layer.

These effects will display the layers in their own special way. The best way to use these modes is through experimentation. They can provide a variety of looks for the art in the document.

A few other options exist for these layers as well.

The symbols next to “Lock:” will lock the selected layer according to what symbol is clicked. A layer cannot be edited while it is locked. If the padlock symbol is clicked, that layer cannot be edited at all. The brush will only lock out any marks made and the arrows will lock out any movements or selections made.

Opacity will change the transparency of that layer. Fill will change the transparency of any mark made on that layer. Sometimes, though, a layer needs to be hidden away so that an artist can focus on the layers below it. Rather than changing the opacity to zero and back to
100%, the layer can simply be hidden or shown again by toggling the eyeball icon next to the layer’s name.

For this character design, there needs to be a new layer so that the final line work can be made without altering the roughs. This layer will stay in its default “Normal” layer mode and stay at 100% opacity.

**Paintbrush Tool**

An array of tools exists to help create work inside of Photoshop. These tools are listed on the left side of the workspace. They include simple tools such as Move, Select, and Crop. There are also incredibly versatile tools that can be used to create a huge variety of shapes and effects. Some of these tools, however, are very rarely used with drawing in Photoshop, if at all. With this sort of character design, the main focus will be on the Paintbrush Tool.

After selecting the Paintbrush tool, there are a couple of menus that appear to change the tool’s settings. The top of the works space has a menu that allows for some minor adjustments, as well as showing the brushes loaded into Photoshop. A symbol representing the current brush has its own dropdown menu that can change the “Hardness” of the brush. A brush’s hardness refers to how feathery or how solid a brush’s stroke can be. This menu can also change the brush’s size (alternatively, the size of the brush can be changed with the “[” key to shrink it and the “]” key to expand it).

The right side of the workspace there is a symbol of paintbrushes in a can. Clicking this symbol brings in a much more in-depth menu for adjusting a brush’s properties. Checking or unchecking these features will activate or deactivate the respective features. Some of these features have additional controls that can be accessed by highlighting them (as can be seen with the Shape Dynamics on the right).

These can be tweaked and experimented with to create a variety of effects in Photoshop. Brushes can be used to create simple lines, but can also create cloud, mist, and a slew of other effects if adjusted correctly. It is even possible to create a brush from scratch. This
character will not require any special effects, however, so the brush will be made for simple lines. A simple brush for this line work can be made with the following settings:

- Hardness = 100%
- Shape Dynamics, Control: Pen Pressure
- Build Up
- Smoothing

**Drawing Line Work**

Line work in any character design will be totally guided by the roughs. The final line work should only refine the shapes already made, and exist to only solidify the idea of the character. While the roughs ultimately will not be used in the final design, they are still essential to create that shape and make a convincing piece.

These are the lines ultimately used in the final design. Drawing something is self-explanatory, but there are some tips to consider when drawing the final lines:

- Creating lines of various thickness and length is known as “line variance”. Line variance can make an illustration look more polished and real. Artists often have the lines of main features thicker than the lines of details. Line variance is yet another factor up to the artist, but should always be considered in when drawing.

- Line confidence is the key in drawing anything. Lines can look confident if they are drawn in a single motion. If this is done correctly, lines will look intentional and planned, even if they are not perfectly placed.

- The term “noodling” refers to spending an excess of time on the details. Spending too much time on small details with a looming deadline results in unfinished pieces. Artists should pace themselves, work rough-to-fine, and know when to move on to another section.

**Coloring the Piece**
In order to preserve the line work, the colors of this piece will be applied on a separate layer. This way, an artist can color the piece and adjust it on its own. Color can be applied to line work by changing the Paintbrush tool’s setting from “Normal” to “Behind”, but this makes adjusting the color on its own problematic. More complicated and detailed characters can all of their parts’ colors separated into its own layer. For simplicity’s sake, however, this character will have its color on one layer.

Coloring a character requires experimentation. Illustrated above is the original color set of this character. Color, in general, can be tricky. The selected colors should serve some purpose, but it can have a variety of effects on people. This character’s colors originally were to convey the idea that this character is poisonous to eat. However, it’s supposed to be cute as well, with its big eyes and nubby legs. Other people critiquing this set were too distracted by the bizarre and clashing colors (especially those of the shell) to acknowledge any of this character’s cuteness.

This is the final set for this character. The new colors are closer to one another on the spectrum. They also are colored to more closely resemble a ladybug, a bug that many people find cute and is also able to convey its poisonous nature. This set read much more positively to people and they were thus able to more easily pick up the intended traits. The creature’s spots were also changed in order to balance the colors of the spots and the rest of the shell.
Note the grid in these images down in the bottom left corner. These are meant for artists who are working with the character. These color palettes serve as a quick reference guide for other artists so they do not have to browse the design for the correct color.

Adobe Kuler

Choosing a proper color palette can be tricky for anyone. Thankfully, when using Photoshop CS6 or newer, there is a feature that can help with this process. Kuler used to be an online program, but is now a default feature for Photoshop. It is meant to help artists choose a color scheme based on a starting color of their choosing. This feature can be found by going to Window ➔ Extensions ➔ Kuler. Once this option is selected, the Kuler feature will appear in the menu to the right.

At the top of this feature is a “Browse” feature, which will look through the Internet to find highly-rated pre-set color schemes. The default, however, is the “Create” tab, which is how artists will create their palette. Various features of the selected color can be tweaked with the sliders below and to the side of the color wheel. Any of the dots can be adjusted simply by clicking and dragging them, and Kuler will set the color scheme according to the artist’s selection.

There is a drop down menu above the color wheel that gives several options for selecting colors, depending on what the artist wants:

- **Analogous**: Chooses colors next to each other on the wheel
- **Monochromatic**: Chooses colors in a line on a the wheel
- **Triad**: Chooses colors on each third of the wheel
- **Complementary**: Chooses colors on opposite ends of the wheel
- **Compound**: Chooses a wider range of complementary colors
- **Shades**: Automatically selects shades of the same color
- **Custom**: Custom build a color scheme from scratch

**Background**

As this design stands now, the pure-white background can be a little distracting. Backgrounds can be whatever the artist decides, as long as they do not distract from the character being shown. There is a very simple way to add backgrounds that takes only a few minutes, and is slightly more than a single color.
This design will start with a duller background color like a pale brown. Another layer will be placed on top of that background, and will contain simple brush strokes that outline the character's positions.

Once that is in place, all that is left to do is to highlight the layer with the white splotches and go to Filter → Blur → Gaussian Blur. This will bring up a box which contains a slider to dictate how much blur to add to the layer. After the slider is set to an appropriate setting, it will be applied after clicking the "OK" box.
This will break up the character’s setting and make it more interesting, but not so interesting that it draws away from the core concept.

**Completion**

Once the character is complete, all that needs to be done is to save it. Save the Photoshop file, and then save a separate image using **File → Save As (CTRL+Shift+S)**. Then simply name the file, and save it as a JPEG.

These turnarounds will give other artists the right idea on the character’s look. Along with these turnarounds, it is a good idea to also draw some poses for the character. These poses should emphasize the intended personality of the character: how it acts, moves, thinks, etc. This character is supposed to be friendly and cute, and has poses that show those traits.

These character designs and illustrations, once completed, should give other artists a very distinct impression of every facet of this character’s identity. It is key for shaping interactions
with other characters, and therefore the entire piece in general. Even though an audience may never see these pieces, they are vital for the development of the final product.

3D Character Rig

While various studios may use their own programs, Autodesk Maya is a very versatile software to use for this situation, and is used by many companies. Animating in 3D has become popular enough to become an industry standard in everything from movies to commercials. Knowing the skills of creating a 3D character can attract the interest of a lot of companies.

This will be the character being displayed in this example:

With the character already designed, it is ready to be created and animated inside of Maya.

Maya
Set Up

This project will require its own folder in order to store all of the materials. The first thing to do when starting a Maya project is to “set the project” to tell Maya where to save everything. This can be done by going to File → Project Window.

This will bring up a dialogue box displaying all of the project’s features.
When creating a new project, simply select “New”. Where the project will be saved can be set by clicking the folder icon and choosing where to save the project. Once that is done, simply name the project and click “Accept”. This creates a regular folder that will hold all of the properties of a Maya file. Files can even be added to these folders so that they can be imported easily into Maya for various purposes.

For a single project, this will only need to be done once. After that, a Maya file can be saved just like any other computer file and will be saved in its designated folder (under the “scene” folder). However, Maya sometimes needs to be reminded where all of the assets are once a file is opened again. This can be done simply by going to File ➔ Set Project. Then find the project folder in the browse window, highlight it by clicking it once, and click “Set”. It is often a good idea to do this every time Maya is opened.

**Moving Inside Maya**

There is constant motion when working inside of Maya. An artist will have to gain a good view of all of the pieces inside of a 3d space so that they know materials are being adjusted correctly. There are the basic tools that can be used to move various components inside of Maya. These tools can be found on the left of the workspace. Three types of selection tools are on the top: the regular Select tool, the Lasso tool, and the Paint Selection tool.

The most important tools in this menu are the bottom three. These tools are vital in manipulating the pieces of the scene. Each of these can either be selected by clicking their respective icon or with their keyboard shortcut. There is the Move tool (W), the Rotate tool (E), and the Scale tool (R).

Moving around in the Maya file quickly is essential for using the program. Moving the view around in Maya can be done with the mouse while holding down the “Alt” key. The three mouse buttons will have different motions while holding down the Alt key: holding the left click will rotate the view, the right click will zoom in and zoom out, and clicking the middle mouse button will pan the camera.

There are also times when a 2d view may be more useful than the 3d view (like with importing this design). With the mouse inside the camera’s view, holding down the space bar will bring up a menu with a huge amount of options. This menu is called the “Hotbox Menu”. The Hotbox menu shows most of Maya’s options right in the viewport of the screen. Holding down the left mouse button over any of these boxes will reveal another menu, which can be selected by dragging the mouse cursor over the option and releasing the button.
Importing this character’s design will require a shift between camera views. This can be done with by selecting the Maya box in the middle of the menu will bring up the possible views inside of Maya. This allows for a quick way to switch between views in only a moment (an incredibly useful ability in character creation).

It is also possible to have multiple views in the Maya workspace at one time. The main window of the workspace has this option under Panels ➔ Layouts. Here, there is a list of available settings for viewing work in the Maya file. It is possible to have as many as four different views of the same object when using this feature.

Any asset that is created inside of Maya can be found in a box called the Outliner. It can be found by going to Window ➔ Outliner (assuming it has not appeared by default). Here, all of the assets of a project are listed. The Outliner also makes it easier to select, rename, and group these components.

**Placing the Character**

The character’s design can be brought into Maya to be used as something similar to a stencil. First, the image should be placed in the project’s folder. Once the image is in the correct location, it can be placed with the “Image Plane” tool found at the top of the camera view.
This character's design is complete, but it was not drawn in a "t-pose". A t-pose is when a character stands with its arms outstretched. Modeling a character this way can make placing everything much easier. Instead of using the design as an Image Plane, there will be a quick sketch made to be imported.

Remember, the camera *must* be set to the respective views before the image plane is set. For the front of the character, the camera's view will first be shifted to the "Front" view with the Hotbox menu.
After switching the view, it's a matter of clicking the Image Plane button and selecting the file. This will be done for all of the angles necessary (in this case, the front and both left and right sides).

Once the images are placed, they can be selected by dragging the mouse over the planes and then adjusted with the scale, rotate, and move tools.
The character will be built directly in the center of the scene. Once the images are placed, the scene is ready.

**Modeling**

Modeling is the process of building the actual shapes of a character, also known as its geometry. Just like drawing the character (or rather sculpture in this case), an artist starts rough and then gradually refines the image. Models can often be started with a simple cube.

First, the scene has to be in “Polygon Mode”. There is a drop down menu with a variety of modes for the scene. Each of these will show different options at the top menu.

Once the scene is set correctly, shapes are created by going to **Create → Polygon Primatives**. This displays a list of basic shapes to be made. This rig will start with the cube. The cube is then repositioned to match the image plane’s image as closely as possible. Using the tools inside of Maya, this single cube will be stretched, cut, and manipulated in order to create the final product.

**Manipulating Geometry**

Geometry in Maya has three different properties that can be edited: vertices, edges, and faces. By right clicking a piece of geometry, a Hotbox menu will appear, where there are options for “Vertex”, “Edge”, and “Face” modes (Object Mode is the default setting). Once a mode is selected, an artist can manipulate the respective pieces of the geometry.

There are several tools that can be used to manipulate the geometry in the scene file. While in Polygons mode, these tools are found in either the **Mesh** or **Edit Mesh** sections. There are a slew of tools in these two sections, each of which have their own uses. There are a few, though, that are used much more frequently than others.

**Extrude**

Extruding creates a new segment in a piece of geometry, adding more to the existing geometry. Once the tool is selected, a cursor will appear to let the artist guide the extrusion. After selecting either a face or an edge, the extrude tool can be selected to extend that selected piece of geometry. The Extrude tool can be found in **Edit Mesh → Extrude**.
Every tool has some tricks to it to gain certain results. For example, the Extrude tool can create quick tubes by clicking the tool, only scaling the new extrusion, extruding again, and bringing that extrusion into the geometry. This method can be used to make things like sleeves on a character.

Insert Edge Loops

Edges can be added to a piece of geometry and automatically loop around that geometry. The Insert Edge Loop tool can be found under Edit Mesh → Insert Edge Loop. This is essentially as a modeler works from rough to detailed in the character. Adding edge loops will also add vertices, which will give the character more dimension for sculpting and editing.

Alternatively, there are other ways to add edges. The Offset Edge Loop tool will place two edges equidistantly from a selected edge. This will prove very useful when modeling joint areas (elbows, knees, etc.) on a character.

Another method, albeit a more finicky one, is to use the Interactive Split tool. This tool can be buggy every now and then, but it can also save a lot of time in some instances. This tool will let the artist decide where how the edge loops will split the geometry*. It can be found under Edit Mesh → Interactive Split Tool.

*Note: Be careful not to break edge flows when using this tool, which is easy to do. Edge flow will be covered under the Edge Flow section.

Slide Edge Tool

Edges can be moved across a piece of geometry without actually affecting the geometry's shape. The slide edge tool does not necessarily help with shaping the geometry. It
will be used in order to adjust the edge flows of certain areas of that geometry (more on edge flow in the “Edge Flow” section). It can be accessed under Edit Mesh → Slide Edge Tool.

**Modeling the Parts**

When modeling a character, each of its separate parts should be modeled separately (i.e. the jacket and the pants should be two different pieces of geometry). Modeling a character essentially relies on the design that has been already created. However, there are some aspects of modeling to take into account.

**Edge Flow**

Edge flow is essential in modeling. A model with good edge flow means that all of the edges of the geometry follow each other in a very smooth pattern. This will make the process of having the model move much easier, as well as prevent penetrating geometry.

Certain body parts also need certain edge flows in order to function correctly. Eyes and mouths are the most important; forming them with circular edges makes them much easier to animate. Animating any part of a character is much easier when edge loops match the forms that reference real life. Real life eyes have a circular formation, and therefore a character should as well.

This is also true for parts such as the chest and waist. Body parts all essentially have a shape to them, and 3d models should try to mimic these shapes. The easiest way to accomplish these loops is to make those shapes first and then shape the rest of the geometry around those edges. Any faces that need to be can be deleted later.
Modeling Joints

Joints have a special way to be modeled to allow for better movement and, again, prevent penetrating geometry. It will also help the skinning process stay somewhat accurate. Joints should have a bump-like shape accompanying them, much like the bulge of a knuckle or knee. Geometry on the bottom of these joints should be pinched closer together, which can be done with the Slide Edge tool.

Symmetry

Typically, characters need to be symmetrical when they are being modeled, unless the design calls for something otherwise. If an artist is modeling a character, they can speed up the process with the Mirror Geometry tool. This tool will copy a selected piece of geometry and flip it over a specified axis. With this, a 3D modeler can essentially halve their modeling time.

The Mirror Geometry tool does have an option to merge the flipped pieces of geometry together. Sometimes, however, merging the geometry can result in some minor problems with the new geometry. Should this happen, the mirror geometry can be undone. Another option is to mirror the geometry and merge the vertices together manually. The Merge to Center tool can be found under Edit Mesh → Merge to Center. Selecting two vertices, then selecting this tool, will merge the vertices together at an equidistant point.

Textures

Textures are what give a 3D character or scene its look. They are either images or generated graphics that can form a certain look. Graphics can either be made directly inside of Maya, or they can be brought in as image files.
In-Maya Textures

Holding the right mouse button over a piece of geometry will bring up another menu. This menu has an option to “Assign a New Material”. This is how a new texture is added, both for in-Maya textures and out-of-Maya textures. There are many options here for a new texture, each one with its own purpose. The most widely used, however, are the lambert (a flat blank texture) and the blinn (a shiny blank texture). Textures are an entire field in themselves, and what is possible with in-Maya textures could take up an entire book. The best way to find out what a texture can do is to experiment with the settings. Any texture can be updated by selecting a piece of geometry and selecting the texture in the attribute editor.

Out-of-Maya Textures

Textures also allow an artist to create an image outside of Maya and plug it into a piece of geometry. The first step to this is to create a UV map for a piece of geometry. UVs are components of geometry that are responsible for creating the texture intended for the geometry. A UV map can be laid over an image, and the map will tell Maya how to contort that image across the piece of geometry.

UV maps are created by selecting the geometry and then entering the Create UVs menu at the top of the workspace. Selecting Automatic Mapping will take the geometry and create a UV map. The problem is that a default UV map will have no reason to it.

An object’s UV map can be brought up by selecting it and selecting Panel → Panels → UV Texture Editor. Default UV maps will resemble something like this:
Some parts of this map are understandable, but it can be more organized. Just like in the normal workspace, UVs can be edited by manipulating edges or vertices. There are some tools are used to help piece UVs together.

- The “Move UV Shell” tool moves an entire section of the map.

- The “Cut UV” tool will separate the pieces of a UV map along a selected edge.

- The “Move and Sew” tool takes a shared edge of a UV map section and automatically moves and connects them.

- The “Smooth UV” tool will make an attempt to smooth any selected UVs to make a more harmonious UV map.

- The “Toggle Shaded UV Display” button will give the map sections some color to indicate whether or not they overlap.

Sections of a UV map cannot overlap one another. This will confuse Maya when it is reading the texture file, and it will result in some bizarre imagery. Any time a piece of a UV map is overlapping another piece, it will show the UV section as a dark blue or a red color (assuming the toggle UV display button is turned on). Once a UV map is cut and sewn together in a more organized fashion, the final result will look something like this:
Once a UV map is created, it can be exported by selecting **Polygons ➔ UV Snapshot** in the workspace panel. This will bring up the options to name the file and determine its size. Bigger files allow for more detail. A generally-good size for these textures would be 2048 by 2048.

**Photoshop**

After creating the UV snapshot, that UV map can be brought into Photoshop. A new layer is made over the UV map so that it can be used as a template. Basically, Photoshop is being used to trace over these UV maps and color in parts of the character.

Once a UV map has been traced completely, the new image will be exported *without* the UV map shown in the image.
This above image is what the final texture file will look like, and is what will be imported back into Maya.

**Maya (Cont’d)**

This texture image is applied by first opening the respective texture inside of the attribute editor (i.e. the head geometry should have its head texture open). Next to the color option in this texture is a small checkerboard. This is an option to replace the color of the texture with an entire new feature. One of the options from this area is called “File”. After choosing file for the new color, a new field will appear titled “Image Name”. Selecting the folder next to this box will browse for the file, which will automatically be applied to the geometry after it is imported.
Rigging
Skeleton

Skeletons in Maya work just the same way as skeletons in real life. Maya skeletons are driven by joints, which are applied manually with the Joint tool (change the menu to "Animation" mode, then go to Skeleton → Joint Tool). Joints are applied to a flat plane depending on what the camera's current view. This is where multiple panels will come in handy (Panels → Layout). With two views right next to one another, this skeleton can be edited from any angle at in the same instance.

Any time a joint is placed, more joints can be attached to it later. This will be done with the joint tool by clicking an existing joint, and then clicking at the next joint's location. Entire chains, limbs, and spines can be formed with a handful of clicks with this method.

IK/FK Arms

The term "IK" and "FK" refer to "Inverse Kinematics" and "Forward Kinematics" respectively. Typically, an arm is rooted at its shoulder. Going down the line, the shoulder moves the elbow, the elbow moves the wrist, and the wrist moves the hand. This is forward kinematics/FK. When the reverse is true—the wrist is controlling the elbow and shoulder—that is inverse kinematics/IK.

These are two different ways a character can move its arms. FK arms would be the default, but it would use IK arms if it was trying to push off the ground or lean on a table. A 3d
character needs a way to blend between these modes. This is done in the skeleton phase of rigging. It will consist of creating a skeleton for three different arms right on top of one another. Two of the arms will be constructed in a similar manner, as just two regular arms. The third arm will be the IK arm.

The IK arm will be built with the same joints as the other two. This one, however, will have an IK Handle attached to it. The IK handle tool can be selected under Skeleton → IK Handle Tool. With the tool selected, the artist has to select the shoulder of the arm and then the wrist. Once that is done correctly, the IK arm will look like this:

This will also have to be done for the other arm of the rig. Once the IK handle is in place, the small crosshair is what will actually be animated in an IK arm. The next step is to parent the regular arm to the FK and IK arms.

Parenting is a process that tells Maya to make one component follow another. Parenting, as well as other constraints, can be found in the animation menu under the “Constraints” tab in the menu. The main arm of the character will be parented to both the FK and IK arms. The shoulder of the main arm is selected, and then the shoulder of the FK arm. While they are both selected, the shoulders can be parented by going to Constrain → Parent. Now the main arm’s shoulder will be controlled by the FK shoulder. The rest of the arm will be constrained in this way, elbow to elbow, shoulder to shoulder. The wrist, however, will be constrained with an Orient constraint so that motions do not interfere with the IK interpretation. Should everything have been done correctly, the main arm will be moved half by the IK arm and half by the FK arm. Controls will be added later on in order to switch between the two modes.
Skinning

Skinning is the process of applying the created skeleton to the geometry. Once the skeleton is applied, the character will be able to move. Beginning this process is simply done by selecting the joints and the geometry to be skinned to one another (i.e. the leg joints and the pants geometry should be selected at the same time). Once that is done, then the skin can be applied by selecting Skin → Bind Skin → Smooth Bind. When skinning, however, the joints for the IK and FK arms should NOT be bound to a skin. Only the main arm should be selected; the other arms will control its motion.

Often times, the original skinning does not go as planned. How the joints influence the geometry (the skin weights) can be edited with the Paint Skin Weights tool. This tool is brought up by selecting a piece of geometry and then going to Skin → Edit Smooth Skin → Paint Skin Weights Tool. When this is brought up, a menu will appear to the left. Each vertex on the geometry has a number value assigned to it from each joint. The higher the number, the more that joint influences the vertex. Selecting a joint in this menu will show what parts of the geometry the selected joint is influencing.
Weights are then edited by painting on the geometry. The options of Opacity and Value will influence the paintbrush when editing the skin weights. There are four different modes on how the brush will interpret the value setting:

- Replace mode will replace the vertex’s value with the selected value.
- Add will add the selected value to the vertex value.
- Scale will multiply the vertex value by the selected value.
- Smooth will attempt to spread a group of values across a section of geometry.
The only real way to test whether or not the values applied to the geometry will work is by animating and moving the rig by hand to test its motion. Animating the rig will be done with the controllers added to the joints.

Controllers

Controllers are what will move the actual joints in the rig. They can be created using NURBS curves, which are 2D lines that will not render in the final product of an animation. They can be made by going to Create → NURBS Primitives → A choice of either “Circle” or “Square”. There are also multiple curve tools in this section that can create NURBS curves from scratch.

Once the curves are created, the joints that they will control can be parented to them. Some features of the controllers must be set first, however.

- All of the controller’s features must be set to zero. This will create a default position for the controller. A curve’s values can be reset by selecting the curve and navigating to Modify → Freeze Transformations.
- The pivot point on a curve must snap to the joint it is manipulating. The controller should rotate and move at the same point as its respective joint so they can move together more harmoniously. A quick way to do this is to select the curve and hold down both the “D” and “V” keys. The first key will make the curve’s pivot point movable by normal means. The latter key will make the pivot point snap to a certain joint.

Once these have been taken into account, the joint can be parented to the curve by selecting the joint first and then the curve controller and going to Constrain → Parent.
Some controllers also need to follow others, but have to move on their own, such as with arm controllers. The elbow needs to be able to move on its own, but also follow the shoulder control. This can be done with groups.

For these instances, the controller that will follow will be put into a group by itself and that group instead will be what follows the other controller. An object can be grouped by selecting it and hitting **CTRL + G** on the keyboard. Just like regular controllers, the group's pivot point also needs to be moved, but to the joint that will control it. Then the group can be selected in the Outliner, then the controller, and then the Parent constraint will be applied.
This will be done for all controllers that need to follow other controllers: spine, arm, and head and neck controllers.

**IK/FK Switch and Set Driven Key**

This character will need to be able to switch between the IK/FK modes for its arms that were covered in the Skeleton section. The switch will be a special controller made for solely this purpose. Maya has a feature known as “Set Driven Key”, which will be used for this switch.

“Set Driven Key” tells Maya that an object’s certain attribute will control the animation of another object. A new NURBS curve will be created to serve as the IK/FK Switch. A new attribute will then be added to it in the Attribute Editor, which can be done by selecting the NURBS controller and selecting **Edit → Add Attribute** in the Channel Box.

Once selected, a new option box will be brought up for the new attribute, with a number of options for it under “Data Type”. For the purpose of this switch, it will need to be a “Float” attribute. Float attributes will be able to scroll through a number of values. This switch does not need an infinite amount of values, so it can be given a range of values (in this case, from 0 to 10). Setting up an IK/FK switch this way should result in something like this:
This new attribute will then be displayed in the object’s Attribute Editor once it is created. It is then ready for the Set Driven Key feature.

Set Driven Key can be found under **Animate ➔ Set Driven Key ➔ Set** with the menu in “Animation” mode. The NURBS curve will have the controlling attribute, so it will be the Driver (the controlling component). The arms’ parenting will be what the controller is manipulating, so they will be the driven. A joint’s parent constraints can be selected with the Outliner. This switch will need the parent constraints of the main arm (not the IK or FK arms) selected.
This controller will be set so that the switch being set to “0” will activate the IK arm, and setting it to “10” will activate the FK arm. Inside of the Set Driven Key box, both the joint’s constraint and the controller’s switch attribute should be highlighted, like so:

Keeping both of these highlighted, the switch will be set to “0” in the curve’s attribute editor. With the switch set to “0”, the “LW0” option (which turns the constraint on and off) should be set to “1” if it is applied to the IK arm or “0” if applied to the FK arm.
This method means that every time the NURBs controller is set to "0", the IK arm will be in control, and the FK arm will be turned off. This will then be done the other way around, with "10" being the setting to turn on an FK arm, and the values of the constraints reversed. The process will have to be done to the constraints of every joint in the IK and FK arms (shoulder, elbow, and wrist).

Animating the Rig

Once the controllers are in place on the rig, it can be animated in a couple of different ways. The controllers can be manipulated to affect the character with the move and rotate tools. Any time a controller is in a planned position, it needs to be keyed. This can be done by simply pressing "S" on the keyboard. Sometimes, however, an artist will only want to key a single attribute of the controller. Should this be the case, the attribute can be animated alone by right clicking it and selecting "Key Selected". Any property keyed correctly will have its field highlighted in red. Any selected object will also show its keys as red lines in the timeline at the bottom of the screen.

Maya does have a setting that, when activated, will automatically key a controller any time it is moved. This feature is called “Autokey”. This feature is toggled on and off by clicking the key symbol in the bottom right corner. With this feature active, however, a controller has to be keyed manually first in order for it to be recognized by the Autokey feature.

Graph Editor

The Graph Editor is an option box that will let an artist manipulate keys much more specifically. Keys in the graph editor will create lines connected to one another.
This feature can be found under **Window ➔ Animation Editors ➔ Graph Editor**. Keys in this window are connected by a line that will represent how smoothly one position will ease into the other. Each of these lines can be edited by moving the key entirely, or with handles that will appear whenever a key is selected. There are also symbols at the top of this menu that will provide various shapes for the keys.

The graph editor is a vital tool, especially at the end of an animation process, when the animation needs small tweaks. When an animation does not capture a particular motion quite right, working the graph editor can easily achieve a desired look for the artist.

**2D Character Rigs**

Animation companies now more typically work with 3d animation in their work. Some companies, however, find a need to animate 2d characters automatically. This is where a 2d animation rig comes into play. Animating in 2d traditionally can take too long for a company’s timeline. Sometimes, it is easier to draw a character and rig it just like a 3d character. This process is almost non-existent in the big studios, but smaller companies might use these types of characters. It may be less glamorous, but knowing how to rig a 2d character can lead to a job in the industry. The reel shows off two 2d characters: a dog, called the “Lucy rig”, and a young girl the “Malorie rig”.

**Photoshop**
These characters have to be drawn before they can be rigged for animation. For the two rigs made for these reels, they are drawn from three different angles: front, three-quarters, and side. This way, the character can turn itself all the way around once it is rigged.

However, the characters cannot simply have each angle on a single layer. Each of these angles needs to be separated into parts based on the position of each body part, as can be seen below:

Placing these parts is usually common sense. When it comes to the above image, for example, having the ear behind the head would make no sense. How a character’s parts are organized will be up to the artist creating the character, and are entirely dependent on its design. The Lucy rig will be operated using Puppet Pins in After Effects, so its limbs can be placed on a single layer (Puppet Pins are explained in the After Effects section).

The Malorie rig on this reel, unlike the Lucy rig, will be driven primarily by constraints and parenting. With this in mind, its limbs cannot be placed on a single layer; forearms are separated from shoulders, calves from thighs, eyes from the head, and so forth. Any part that moves independently will be drawn on its own layer.
Also unlike the Lucy rig, the Malorie rig will have several components to shuffle through in its final result. Blinks will be operated this way, so the eyelids and eyes have to be drawn separately. The hands and mouth will each have several positions, each of which need to be drawn separately as well. Once the rig is finished, a controller will be able to shift between each hand and mouth. How many mouths or hands an artist should draw really depends on how the character will be used. This rig is a pretty generic one that is tied to no specific purpose, and so it has enough hands and mouths to cover any possibility.

Placing all of these components of a character in the correct order will make it much easier to edit them inside of After Effects. Once a character has all of its components in place, it can be imported into After Effects.* Also, it should be noted that every layer is placed into a
group depending on the angle to which it belongs. An important note: all layers of an angle need to be grouped together. After Effects will preserve these groups, and make rigging the character both easier and faster.

*Note: More components can be added later, either by updating the Photoshop file being imported or by importing another file.

**After Effects**

**Importing the File**

Importing a file into After Effects is as simple as going File \* Import in the top menu. Selecting this option will open a browse window that is used to find the file to import (i.e. the Photoshop character file). Once the file is selected, a dialogue box will appear to ask how the file should be interpreted. This file should retain the groups established in the Photoshop file, so these should be the appropriate settings:

Once the file is imported, all of the components of the imported file are shown in the menu on the left of the workspace under the “Project” tab. The entire Photoshop file is shown as its own group or “composition”. Clicking the arrow next to the Layers folder will reveal all of the Photoshop layers by themselves, as well as all of the groups made in the Photoshop file as compositions.

Compositions in After Effects have all the same functions of groups in Photoshop. These rigs will have all of its
respective components placed inside the appropriate compositions to keep things organized.

**Setting Up the Rigs**

**Lucy**

Each rig needs to be set up correctly before all of the codes and constraints to make it move are placed. These rigs will be organized in different fashions. The Lucy rig will have all of its angles separated and will be animated independently. The Malorie rig will shuffle components so that its parts can be turned individually.

Again, setting these files should be organized already thanks to the Photoshop file. Once a composition for one of the angles is double-clicked, it and all of its parts can be seen on the timeline menu at the bottom of the screen.

**Malorie**

The Malorie rig will be organized differently and require a bit more work. While the Lucy rig can use the established Photoshop groups, the Malorie rig will not (though the groups make it much easier to keep track of the layers). Instead, each of the Malorie rig's components will be organized into their own composition based on body parts. There will be a composition for the head, the torso, the waist, and so forth.

A new composition can be created by simply going to **Composition → New Composition** (CTRL + N) in the top menu. This will bring up a dialogue box to ask about the composition's settings and name.
The only real important section of this box (at least for now) is the “Composition Name”. This should be named to reference whatever body part the composition will contain in order to avoid confusion. After this step is completed, the new composition will automatically be brought into the timeline menu.

Once that is finished, the respective layers should be brought into the new composition. This can be done in two ways. Either A) find the respective layers in the Project tab and drag them into the new composition, or B) open all of the angle compositions and copy-and-paste the needed layers into the new composition. Layers can be renamed whenever necessary by right-clicking and selecting “Rename”. These layers in the new composition need to be placed right on top of one another (see below). That way, the part will rotate convincingly when animated. It is also best to have these parts create a turn when layered on top of each other. So, in this case, the layers are the front, 3 quarters, and side view when read top-to-bottom.

This will be done for the torso, neck, waist, legs, and arms. Because the head has so many parts to it, however, each of the head’s angles will be a composition.
Each of those compositions will be placed in a single “Head” composition. The composition containing all three angles is what will ultimately be animated.

The back of this rig’s hair will be its own composition with all three angles, and will follow the head. That way, that part will sit behind the neck and the shoulders. For that composition, each angle will have its own composition as well. This for rigging up the hair so that it can bounce (which is covered later on).

All of the compositions of the different parts of the rig will be placed inside of another composition to house the entire character. This should be named something to indicate it is the main rig, like “Rig Main” or something similar. Just as in the Photoshop file, these layers need to be placed on top of each other in a logical order.

It is also important that, once the compositions are completed and placed, that their anchor points should be adjusted. An anchor point is the point around which the composition will rotate. Where the point should be placed depends on where the part will rotate. For example, a person’s head will rotate where it meets the neck, so the point of the head composition should be moved to where the head will meet the neck. This is done with the “Pan Behind Tool”. It can be selected at the top of the workspace, or with the “Y” key. Once selected, the anchor point will appear as a small crosshair that can be simply dragged into place.
Controlling the Rig

Lucy

The Lucy rig will be driven primarily by the Puppet tool. This tool will hold down certain parts of an image with small dots called “pins”. This pins can later be animated, and therefore drive the image. It can be found at the top of the screen, or with (CTRL + P).

These pins should be placed wherever there is a joint or something to be held down. The neck to the lower right, for example, will only have the top pin move. All of the other pins will be used to keep the mesh from distorting the neck incorrectly.

Once the pins are placed, the next step is to parent them to “Null Objects”. These are layers containing a single blank square. They will be the parts that are actually animated. A rig will all of its null objects in place will resemble something like this:

Null objects should be placed so that they are not too jumbled or confusing. While there are quite a few objects in the example above, they are placed so that they are easily accessible to an animator. It also helps to change the color of each null object depending on what it controls (the above example has its front-leg controls red and its back-leg controls yellow). This can be done by clicking the color box next to the null object layer by the timeline.
Pins can be parented to null objects, but it requires a bit of coding. First, though, the anchor points of the null object being parented needs to be placed over the respective puppet pin as closely as possible. A null object’s anchor point is what will actually control the movement of the puppet pin. The null objects themselves, however, can be placed wherever they are the least intrusive.

Code can be placed into a layer by opening the drag down menu to a layer to open all of the layers properties to find the appropriate property to be edited. For this instance, the puppet pin is being edited. After finding the correct puppet pin, clicking the stopwatch icon while holding the Alt key will bring up the text box for entering code. This is the code used for these instances (replacing the bracketed words):

```
n=thisComp.layer("[null object's name]"icted);  
nullpos=n.toComp(n.anchorPoint);  
fromComp(nullpos);  
```

If everything is done correctly, the timeline will look something like this:

This process will be repeated for all parts that are controlled by puppet pins (limbs, ears, neck, etc.) inside of each angle composition of the Lucy rig.

**Malorie**

Much of the parts of the Malorie rig will be controlled with parenting. Just like the constraint system in Maya, After Effects has the ability to parent parts together. This can be done with a simple drag of the mouse.
Each layer in the timeline has a spiral symbol next to it under a column titled “Parent”. If this column is not visible, it can be shown by opening the timeline’s dropdown menu and selecting Columns → Parent.

Parenting one layer to another is done by holding down the left mouse button over that layer’s spiral symbol, dragging to the layer that will be its parent, and then letting go of the mouse button. Once a layer is parented, it will show the name of its parent in the box to the right of the spiral symbol.

Photoshop layers can be parented to null objects in order to make them move. This is the core operation of the Malorie rig. Just like the Photoshop layers, the null object’s anchor point should be positioned to the point around which it should rotate with the Pan Behind tool.

There are also some applications for the Puppet tool in this rig. Seeing as the torso is a single image, it will be driven by the Puppet tool as well. Other pieces, such as the waist and
hair, will also be animated by applying the Puppet tool. Compositions can be edited with the Puppet tool as well. The hair and waist pieces may need to be rigged individually, but the entire torso composition can be rigged in order to save some effort.

Each part of the Malorie rig will be rigged for animation and become its own moveable composition. All of the moveable heads, limbs, and torsos will then be put into a single rig for each body part. Then, all of those compositions will be collected into a single composition that will be able to control all of the individual parts at once (as well as shuffle the visibility of different angles).

For example, this is one of Malorie’s rigged legs:

All of its parts—foot, calf, and thigh—are rigged so that it can be animated. This leg is the side-angle leg that will be facing the screen, so it and all of its controls are under a composition titled “SCRSideLeg”. This process is repeated for the front and 3-quarted-angle leg as well. All of these compositions are placed in a single composition titled “ScreenLeg”, like so:
This composition carries all of the legs that will be closest to the screen (a visibility switch for the different angles is covered in “Slider Controls”). Once assembled, it will be placed in the main puppet rig that will house all of the main controls for the Malorie rig.

These compositions are also made for the torso and head. Without any adjustments, however, these compositions will show all angles of the leg at the same time. This is where slider controls can be useful.

**Slider Controls**

Slider controls will be able to change the visibility of part of a character. The Slider effect is what will control whether or not a certain body part is visible at any given moment. Effects can be found in the Effects & Presets menu to the right of the screen. If an artist is looking for a
certain effect, they can simply type it into the search bar and drag it over to whatever layer it will effect.

Once the effect is placed, it can be accessed through the Effects tab while the layer is selected.

These sliders can be renamed to whatever an artist would like. This is important when a controller will manipulate multiple features (like the head control above manipulating both the head angle and mouth position). Effects can also be accessed by using the dropdown menu by the layer name by the timeline under “Layer Name” → Effects → “Slider Name”. Any effect under the layer can then be renamed by right-clicking them.
A range will need to be set for the slider, as well. A slider’s range can be changed by right-clicking the “Slider” option under its name and clicking Edit Value. This will bring up a small dialogue box for the slider, where the range can be changed by changing the yellow-colored numbers next to “Slider Range”.

A slider’s range is varied upon its purpose. The slider control for the Malorie rig’s torso, for example, is set from 1 to 3. There are three angles for the slider to shift through, so it has three values.

This rig will also have slider controls to shuffle between mouth and hand positions. These slider controls will have very different numbers. Each mouth composition has 23 different mouth shapes. Therefore, the slider control that shuffles between mouth positions will have a range of 1 to 23.

Slider controls should be placed strategically, which is fairly straightforward. The slider control that changes the torso’s angle, for example, would be applied to the torso’s main control (titled “Chest” on the Malorie rig). Once the slider controls are in place, the next step is to tie it to a composition’s visibility. This will require another bit of coding.

For each composition, the property that the code manipulates will be the “Opacity”. With this in mind, the stopwatch icon next to “Opacity” should be the one selected when entering the code.
In this example, the slider control for the torso will begin on "3". When the slider control's value is set to "3", it will display the front angle of the rig's torso. This will be accomplished with the following code:

```plaintext
Angle_Slider=comp("[Main Composition]").layer("[controller]").effect("[slider's name]"("Slider");
if(Angle_Slider==3){
  100;
}else{
  0;
}
```

Again, all of the bracketed names must be replaced according to the situation. For this rig, the slider control is on the “Chest” controller, the slider is titled “Angle”, and the main composition is called “Malorie MAIN”. With these factors, the code will look like this:

```plaintext
Angle_Slider=comp("Malorie Main").layer("Chest").effect("Angle")("Slider");
if(Angle_Slider==3){
  100;
}else{
  0;
}
```

The side image of the torso, however, should be set so that any value between 1 and 2 will display it. After clicking the icon by the side view’s opacity, the following code is entered:

```plaintext
Angle_Slider=comp("Malorie Main").layer("Chest").effect("Angle")("Slider");
if(Angle_Slider>=1 && Angle_Slider<2){
  100;
}else{
  0;
}
```

The angled view of the torso will be shown between 2 and 3, so this code is entered for the angled torso’s opacity:

```plaintext
Angle_Slider=comp("Malorie Main").layer("Chest").effect("Angle")("Slider");
if(Angle_Slider>=2 && Angle_Slider<3){
  100;
}else{
  0;
}
```
Entering the codes correctly should result in something to this effect in the timeline:

Now the slider control will shuffle between the visibilities of the different torso angles. Unfortunately, this has to be done for every angle of every limb, changing the values depending on the angle. This also means that the visibility has to be switched for the 23 mouth shapes at each angle, and the 15 hand shapes at both angles (which is a total of 99 shapes). Needless to say, this is an incredibly tedious process with a lot of copy-and-paste work, but it is a necessary one. Once it is finished, however, the result is a quick way to animate and switch between different angles and mouth shapes.

Thankfully, something like the Lucy rig is nowhere near this complicated. It does have slider controls (one for the body and another for the head), but it is only used to switch between rigs in the render view. This is a viable option, but may make the rig more complicated to animate. As can be seen below, this set up means that an animator has to enter every composition in order to animate it.
Parenting Controls in Separate Compositions

The Lucy rig is a more simply-made rig, with each of its angles separated into its own component. The Malorie rig, however, will have all of the controls for its arms, legs, and so on, controlled by a single master controller. This is done by parenting the in-composition controls to the controls in the master composition.

This is problematic, as the spiral symbol trick will not transfer to other compositions. Instead, this is done with a bit more coding. What code to use depends on how a certain body part should move. The rig’s thigh, for example, does not move around freely. Rather, it rotates on a fixed point. With that in mind, the in-composition controls will have their “Rotation” properties altered. After Alt-clicking the stopwatch symbol next to the in-composition’s control, this code will be entered:

```plaintext
DC_Rot=comp("[Main Comp]").layer("[master controller]").transform.rotation;
transform.rotation+DC_Rot;
```

Bringing back the leg example, this code could be entered in the screen-side leg’s thigh controller.
For this instance, the master controller for the screen-side thigh is titled “Leg 1”. This would mean the code for this instance would look like this:

\[
DC_{\text{Rot}} = \text{comp("Malorie Main").layer("Leg 1").transform.rotation; transform.rotation+DC_{\text{Rot}};}
\]

After entering this code, any movement of the main composition’s leg control will move the leg control for this leg. This only works for rotation, however; the controls will rotate together, but freely moving them does nothing.

Some body parts, like the rig’s eyes, will be able to move freely. The in-composition eye layer is parented to an eye controller. Now the eye controls in the main composition needs to be able to move the in-composition eye controller. The code to parent rotation has the abbreviation “Rot” for “rotate”. Making the code apply to position is as easy as chaining the “Rot” to “Pos” and chaining any instance of “rotation” to “position”. With that in mind, parenting the in-composition’s eye controller to the main composition’s eye control—tilted “Right Eye”—is a matter of applying this code to the in-composition controller’s position attribute:

\[
DC_{\text{Pos}} = \text{comp("Malorie Main").layer("Right Eye").transform.position; transform.position+DC_{\text{Pos}};}
\]

This also applies to scaling the controller, which will scale the eye.

\[
DC_{\text{Scale}} = \text{comp("Malorie Main").layer("Right Eye").transform.scale; transform.scale+DC_{\text{Scale}};}
\]
All of these codes are appropriately applied to all of the in-composition controllers in the rig. It may have become apparent that rigging in After Effects can be an overall tedious affair. Once it is complete, however, it allows for a believable character that can be animated fairly quickly.

**Animating the Rig**

Animating in After Effects has some similarities to animating in Maya. Beginning an animation involves setting the character into its starting position. Then the property of the controller to be animated should be selected. There are two ways to make After Effects recognize that a controller can be animated: either click the stopwatch next to the property, or by going to **Animation → Add “Property” Keyframe**. Multiple aspects of multiple layers can be selected by selecting the layers and then pressing the first letter key to whichever property that should be animated ("P" for position, "R" for rotation, etc.).

If multiple properties of a controller are to be animated, then all of them must have their keyframes set in one of these ways. Once the keyframes are activated, however, there is an “Autokey” option inside of After Effects. Just like in Maya, After Effects will create a new keyframe for a controller every time it is edited. Remember that slider controls can be animated as well.
Animations can be altered with deleting and moving key frames. The timeline will show any key frame (shown as a small diamond) that a controller has in an animation, which can be moved and adjusted to an artist’s liking.

Any controller with animation will also show its path on the screen whenever it is selected. These paths are made up of dots, which can be used to alter animation as well.

Once an animation is completed, it can finally be rendered into a final video. This will be a process covered in this next section.

**Pen Render Test**

Companies would like to see that an artist knows how to make an image look convincing in the final result. This is the idea behind a pen project that is briefly shown in the demo reel. It makes use of lighting and rendering systems inside of Maya in order to create a convincing image on screen. Displaying this quick render will show some proficiency in Maya tools that extend beyond just animation. This project shows not only the ability to animate something, but to also make it look well done.

It is important to note that rendering a scene correctly can require a lot of guess-and-check work. Any given frame at any given moment can be tested with the “Render Current Frame” button at the top of the menu. Realistic renders will often require an artist to adjust settings, test the render, adjust the settings again, and repeat.
Maya

First thing to do in order to create this project is to model and rig the pen. This is a simple rig, with only the button and the pen itself being the real moveable parts (this is all that is needed for this sort of project).

This project also needs a blank background that has the ability to help light the scene. The easiest way to do this is to create a large plane under Create ➔ Polygon Primitives ➔ Plane. Clicking the option box next to the Plane option will give the option to add more geometry to the plane. Naturally, there are several ways to turn this plane into a background. This project will select the plane’s middle vertex, turn on Soft Select (short cut b), and move the entire selection down to create a pit. A blinn material will then be added to the plane, and the reflectivity will be raised.

Textures

All of the textures of this pen are done inside of Maya. This project uses blinn materials so that the pen has a newer look to it. Metal parts of the pen -- the tip, the clip, and the button—are all meant to have a very metallic look to them. This can be done by adjusting the material’s attributes, namely the diffuse, eccentricity, and the reflectivity.

This pen’s main body is meant to be made out of a clear plastic. This transparency can be adjusted with a material’s “Transparency” option. The other option to edit is the material’s refractions. Refractions in a material’s menu can be found under the “Raytrace Options” dropdown menu, where there is a checkbox for refractions, and various settings for the refractions.

Real life objects do carry something called a refractive index. This is a number assigned to a material to explain how refractive it is (a material’s index can be found with an Internet search). A material like this plastic has a refraction index of around 1.25; placing this number in the “Refractive Index” option under the Raytrace options. As an artist tests their work with renders, they may want to adjust this number.

Lighting

The look of an object can be changed dramatically with the right lights placed in a scene.
Lights can be created in a scene by going to **Create ➔ Lights**. Selecting this option lists a menu of the various types of lights that can be made. This scene needed directional lights to illuminate the pen. Spot lights will work well for this type of scene.

Both the real world and Maya can use a basic set up for lights called “three-point lighting”. Lights in this arrangement consist of three different lights: a key light, a fill light, and a back light. The key light and fill light both illuminate the subject from opposite sides while focusing on that subject, creating a V-shape. The key light is meant to be the main source of light, so it is more intense than the fill light. Both the fill light and the back light are meant to counter-act any shadows that the key light will make; they have a presence, but have weaker intensities than the key light. Generally-speaking, a key light will be twice as intense as a fill light, and a fill light will be twice as intense as a back light.

The attribute editor of a light has a variety of features, including intensity. Three-point lighting makes a great starting point for setting a scene, and will do well with this project. However, this is just a starting point. Lights can be adjusted, added, and removed in order to make a scene look convincing. Lights are yet another skill with no one right answer, and their placement is all based on an artist’s judgment.

**Rendering**

Once the scene is lit and complete, it is ready to be rendered. Rendering is when the computer takes all of the information inside the software (in this case Maya), and translates it into image or video form. What Maya does in the rendering process is actually translate all of the information in the file into separate images. These images can later be sequenced together in another program. This may seem overly-complicated, but can actually help in some situations. With this method, different sections of a file can be rendered at once, and so multiple computers can render a scene and speed up the process. This process also protects an artist should they lose some images or have Maya crash. It keeps all of the information of a render from being completely lost.

**Ambient Occlusion**

An important feature to add before beginning a render is an Ambient Occlusion pass. Ambient occlusion is a render of a scene that will help solidify the shadows and lights of a scene, making it look more like a 3d space. Selecting the Channel box on the right side of the screen will show the potential layers in a scene. Adding an Ambient Occlusion pass involves selecting the “Render” option in these tabs and creating a new layer there. Once the layer is created, all of the lights and geometry need to be added to that layer. This can be done by selecting the lights and geometry (either manually or through the Outliner), right clicking the name of the occlusion layer, and selecting the “Add Selected Objects” option.
Notice that there is an Overrides option in the menu above. This will how the ambient occlusion will be applied to this layer. With this layer selected, the next step is to navigate to Overrides → Create New Material Override → Lambert. This should convert all of the geometry into a blank lambert.

Once the lambert is applied, the next step is to change its color setting. The color can be edited by clicking the checker box next to the color option. The ambient occlusion shader will be replacing the color of the lambert. This shader can be found under Mental Ray → Textures when the dialogue box appears. The ambient occlusion shader will be called “mib_amb_occlusion”.

Adjusting the ambient occlusion will require more testing amongst all of the features. Some of the features will add significant time to how long it takes to render the scene. Sample size is the main culprit for this problem, as it adds more information to the scene. Settings for this shader will be different depending on what is happening in the scene. The final product of this shader should resemble something to this effect:
All of the original textures and animations to the original pen are still in the file. They are just placed in a different render layer. During the render process, Maya will render both of these layers, and they will be joined together to create the final product.

**Render Settings**

A scene's render settings need to be set before rendering the scene. Render Settings can be opened with its respective button at the top of the workspace. There are many options in this window, but there are a few that require a bit more attention.

- The “Render Using” menu will decide what rendering method Maya should use. The “Mental Ray” option will always yield the highest quality results.
- Image format should be set to “Targa (.tga)”.
  These types of images will save the most amount of information from the Maya file
- “Frame/Animation ext” will display how each image will be named when it is rendered. These options are up to the artist, but it is always best to have the file's extension (.ext) at the end of the image's name.
• "Frame Range" sets how much of the scene to render. Sometimes, the entire project does not need to be rendered at a given time.
• "Renderable Camera" decides what camera view Maya will use to interpret the information on screen. The default camera can be set up for this, but it is sometimes easier to create a new camera (Create → Cameras) just for this purpose.
• "Image Size" dictates how large the images will be and how the detail of their resolution. The size of the image will depend on the project. However, it is always a good idea for the resolution to be at a decent level, such as at least 150.

Batch Render

Once the Render Settings have been made, it is time to create a Batch Render. A batch render is the term for Maya rendering every image in the entire scene. With the top menu changed to "Rendering", the Batch Render option can be found under Render → Batch Render. Once that option is clicked, the render will begin. A Batch render can also be canceled at any time with Render → Cancel Batch Render. The progress of a batch render can be seen either by going to Render → Show Batch Render or by opening the script editor, which is located in the bottom right corner.

Once the batch render is completed, all of the images can be found inside of the project's folder under "images". This is location from which After Effects will import these images.

After Effects

Importing Image Sequences

Maya’s rendering process created a very large amount of images. Once these images are pieced together, they will create an animation image-by-image. This pieced-together final product is called an “Image Sequence”. These images can be imported into After Effects to create an image sequence.

After Effects' import setting must be set correctly before importing an image sequence. Maya rendered these sequences under the a set framerate, and so After Effects must import the sequence at the same rate. This can be edited by going to Edit → Preferences → Import. Clicking the number under “Sequence Footage” will change the frame rate at which After Effects will import image sequences. The default is set to “30”. This project was rendered at 24 frames per second in Maya, so this number will be set to "24".
Once that is set, the sequences are ready to be imported. All that is left is to go under **File → Import → File (CTRL + I)**. Then find where the images are located, select the first image of the sequence, and click the “Import” button (remember to have the “Import As” option set to “Footage” and to have the “TGA Sequence” box checked). For this project, this will have to be done for both the Master sequence and the ambient occlusion (AO) sequence.

**Compositing Sequences**

Imported sequences will be shown as compositions in the Project tab to the left. Once they are imported, the two sequences should be dragged-and-dropped into the timeline, with the AO sequence placed over the Master sequence. Then the AO sequence will have its layer mode changed to “Overlay” by right-clicking it and going to **Blending Mode → Overlay**. If all of this has been done correctly, the final result will be something like this:
With the AO sequence set to “Overlay”, it is acting as a screen over the Master image sequence. It will lay the shading of the ambient occlusion render without completely covering the master render. This process is fairly standard for all animation projects, though bigger projects can become more complicated. Once these layers are in place, the final product is ready to be rendered.

**Rendering**

Rendering inside of After Effects is the quickest step in this process. A work can be rendered once it is added to the Render Queue. This is a list of all of the work that will be made into a completed video file. After Effects Render Queue can be accessed by hitting CTRL + M on the keyboard. The render queue will look like this:

![Render Queue](image)

The settings in the Render Queue can be edited by clicking on the yellow text. Render settings will let an artist change the quality of the video, its size, frame rate, and more.

For most projects, the most important area is the Output Module. This is the area to set a video’s format. If set correctly, the final video will be high quality without being an unbearably huge file. There are a slew of options in this area, each of which has their own particular purpose. With most projects, however, a well compressed video file can be created with the following settings:

![Output Module Settings](image)
Once these specifications are met, all that is left to do is select where to save the file. This is set by clicking the text next to “Output To” in the Render Queue. This brings up a default dialogue box that will ask what to name the file and where it should be located. Wherever the artist picks is where the final product will be saved. The final step in this process is to click the “Render” button to the far right. After Effects will then process the information, and save the file to the selected location. With that, the project is complete.

**Conclusion**

There has been a lot of work placed behind these projects. Each one has its own share of hardships and problems. However, all of these projects are just a tiny sample of what is possible to make in these programs. This document is a beginner’s guide because it is specifically meant to only give a taste of what is possible.

Despite the vastness of these programs, it can still be overwhelming to some to perform with even basic tools of the program. Anyone that may be feeling this way about computer art should start with only one goal: experiment. Learning these programs is just like learning any other computer program. The best way to learn something is to play with all of the components inside of it. People can learn how to use a program by simply clicking some buttons and experimenting with the results. With this guide, someone can open the included CD-ROM and examine these files themselves firsthand. All of this guide can be a good start, but it is only a stepping stone to the learning process.